Assistance Requested for my TS950SDX

The Black Art of tweaking the Voo in the Doo...
Post Reply
wd4ngb
Audio Head
Posts: 2
Joined: Fri Apr 18, 2014 6:31 am

Assistance Requested for my TS950SDX

Post by wd4ngb » Fri Apr 18, 2014 8:09 am

I am having audio problems. The audio of my 950SXX sounds restricted, no matter what mic I use. I went into Menu 20 and 21 to see what I could do for it. The radio responded very well to changes in Menu 20, but any changes in Menu 21 did nothing. I tried a Master Reset, and still the same, Menu 21 does not change the audio at all.

Any ideas on what to check? I was inactive for a few years, and trying to get back into things.

Tried my MC60, old Heil Proset with a #5 element, and new Heil 6, all seem to be restricted audio.

Bruce

BillPaul
Digital Voodoo Guru
Posts: 66
Joined: Wed Jan 19, 2011 11:52 am

Post by BillPaul » Fri Apr 18, 2014 2:27 pm

You left out some information:

- You said you changed settings in menu options 20 and 21, but didn't say just what settings you tried.

- You didn't say what means you used to evaluate the audio. (Are you listening via the monitor with a pair of headphones? Listening on a second rig? Getting radio checks from a friend?)

- You didn't say what mode you're using (AM, or USB/LSB).

- You didn't say if your radio was sitting idle so long that the internal battery died, or if you did a CPU reset.

The reason I ask about the mode is that in AM, menu 21 doesn't typically have much of an effect. Even though the interface lets you select different settings, I think the max top end bandwidth always stays at 3100Hz. Lower settings aren't very useful on AM anyway. On sideband though, you can definitely hear the difference as you cycle through the settings, though only if you listen through the monitor with the cans on.

To get hi-fi mode (or "wide glide" mode as it's sometimes called) to work, you also need to use a couple of special power-on menu settings. If you radio has been idle long enough that the battery died, or if you did a CPU reset (press and hold the A=B button while turning the radio on), then these settings may have been lost.

Fortunately, it's easy to restore things. There are two key procedures:

Allow setting of analog filters in TX and well as RX
----------------------------------------------------
1) Start with the radio off
2) Press and hold the SCAN key and the right M.CH key while turning the radio on
3) Use the small encoder knob to select menu option 1
4) Press the UP arrow key to change the setting from "off" to "on"
5) Press the CLR key to exit the menu

Enable "off" setting of LPF menu (21)
--------------------------------------------
1) Start with the radio off
2) Press and hold the FINE key (to the left of the VFO knob) while turning the radio on
3) That's it, you're done.

Without the second procedure shown above, when you cycle through the menu 21 settings, the highest you'll be able to go is 3100Hz. With the procedure completed, there will be an additional "off" setting, just like there is for menu 20. Both menu 20 and 21 must be set to "off" to get full hi-fi audio.

You also need to set things so that the 8.83Mhz IF filter is disengaged. The first procedure shown above allows you to do this (normally the 8.83 and 455 filter selection buttons only work in RX -- the trick above lets them work in TX too).

You can configure the radio for Hi-Fi audio as follows:

1) Press the MENU key
2) Set menu options 20 (HPF) and 21 (LPF) to "off"
3) Key the transmitter in the desired mode (LSB, USB, AM)
4) Keep pressing the 8.83Mhz IF filter select key until the "bypass" setting is reached (all filter lights off)

The 455Khz filter selection has no meaning for transmit, only for receive.

Using the rig for hi-fi AM mode won't work unless you have a chip with my modified firmware installed, but it's not clear if you care about that. With the above instructions, everything should work ok in LSB/USB modes.

Hope this helps.

-Bill, N1GPT

wd4ngb
Audio Head
Posts: 2
Joined: Fri Apr 18, 2014 6:31 am

Post by wd4ngb » Fri Apr 18, 2014 4:37 pm

Thanks for the reply.

I used the Monitor function with head phones, and also verified the action with on the air qsos. All done in SSB.

I tried all the settings in both 20 and 21. In menu 20, the radio responded normal with each change.

I did a CPU Reset, and it did not solve the problem. The battery seems to be still OK, as every thing else is normal.

When I did the Turn ON while holding the buttons to get the OFF option in 20 and 21 it worked, and I checked that I did not have a carrier when I checked it in AM, so all seemed to go as it should.

Still no change in any settings in menu #21 from 2600 to 3100, and off, the audio stayed the same.

I tried this,

1) Start with the radio off
2) Press and hold the SCAN key and the right M.CH key while turning the radio on
3) Use the small encoder knob to select menu option 1
4) Press the UP arrow key to change the setting from "off" to "on"
5) Press the CLR key to exit the menu

and the audio sounds full now and much better. Went back r=and checked the settings on menu 21, and no matter which one is selected, the audio does not change. Checking menu 20, with each setting the audio changes as it should.

The radio sounds much better after doing turn on with Scan and right M key pressed and setting #1 from off to on, but the menu 21 does nothing.

With the Heil proset 6, I have to turn the mic gain to full on to get any where near normal level of audio. May need to ship this thing off to the doctor? Thanks for the help.

Ideas?


Bruce

User avatar
Voodoo Guru
VooDoo Site Admin
Posts: 718
Joined: Wed Feb 23, 2005 8:47 am
Location: Down there on the right...

Post by Voodoo Guru » Sun Apr 20, 2014 5:35 am

As always Bill gave a very correct and on the money post, Thanks Bill.

He alluded to the main problem that you are having in that if you are listening with the STOCK TX Monitor in the SDX then that is the problem that your hearing with the bandwidth. The stock TX Monitor uses the Sub Receiver to receive and demodulate the Transmitted Signal. The Sub Receiver uses a 2.1Kc Filter in its IF, so anything wider then that on the actual Transmitted Signal will not be heard with the unmodified 950 TX Monitor.

You either need to use another Receiver with enough receive bandwidth to monitor the transmitted signal, or modify the 950.

Some other things that may be contributing to the problem for the listeners over the air would be your choice in narrow frequency response microphones and the actual receive bandwidth of the rigs the listeners are using.

Take Care,
Voodoo Guru
From Deep in the IDD of the Sub-Harmonix Realm

BillPaul
Digital Voodoo Guru
Posts: 66
Joined: Wed Jan 19, 2011 11:52 am

Post by BillPaul » Wed Apr 23, 2014 12:47 pm

Just to be clear, there are two phases here:

1) Use some power-on tricks nable a couple of hidden features

2) Make use of those features later

To simplify it:

Phase one:
- Press and hold FINE key while powering up
- Press and hold SCAN + right M.CH key while powering up and set service menu option 1 to on

The first thing lets you set menu 21 to "off." You keep saying that you tried all possible menu 21 settings, but haven't confirmed that you specifically tried the "off" setting. I wanted you to do that so that we could be sure you got this step right.

The second thing lets you unlock the 8.83Mhz and 455Khz filter settings during transmit. It doesn't actually change the settings: it just allows you to do it, which you will as part of phase two below.

Phase two:
- Set menu 21 to "off"
- Key the transmitter and keep pressing the "8.83" button to cycle through all the different settings until you get to the one where all the indicator lights are off -- this is the bypass position

NOTE: if you don't key the transmitter, pressing the "8.83" button only changes the filter configuration for receive -- you must set the "8.83" and "455" controls with the transmitter keyed in order to have them affect transmit. (The radio remembers the state for both separately.)

Note that the 455Khz filter setting doesn't have any effect on transmi in USB/LSB modet: the filter width at the 455Khz IF level is controlled by the DSP.

At this point, you should hear a noticeable difference in your transmitted audio, as completing these two settings should put you at 6kHz bandwidth. Even with the monitor unmodified, I was always able to detect some difference in the high end response. It may not be that obvious until you perform the second step of phase two above, which should disengage the analog filter at the 8.83Mhz IF stage. If I remember correctly, I think that by default the "2.4kHz" indicator in the 8.83 filter column always lights up when you transmit on sideband (and without the unlock trick you're unable to change it). This might be why you don't hear a lot of difference when you change menu 21 now. Once you set the analog filtering to bypass, the bandwidth will be limited only by the DSP unit, which is controlled by menus 20 and 21.

Note that with the analog filter settings unlocked. you can now do all sorts of crazy things like transmit in USB/LSB modes through the CW filters, which is kinda useless but doesn't hurt anything.

-Bill, N1GPT

User avatar
ECC82
Voodoo Audiophile
Posts: 73
Joined: Tue Jul 03, 2012 1:06 pm
Location: The Netherlands

Post by ECC82 » Sun Apr 27, 2014 11:12 am

Very helpful thread, tnx. Was fine tuning the equipment but not getting the result I hoped to achieve. Most settings in the menu were OK but now learned a few extra settings and on the TX monitor (modified 950) the result is satisfactory :supz:
===================
>> Livin' la VooDoo Loca <<
===================

Post Reply